The server is not available, retrying in 3 seconds

ros

#1

I have downloaded the demo. Started the server and configured users. After that, I started the Mac Demo and the Xamarin forms demo. Both works fine and I can see the Realm in the website

http://localhost:9080/realms

The issue is that, in the guide, it says open the Realm Browser which was not included on the folder. I download the Realm Studio V 2.0.0 and tried to connect to the self-hosted local server but it’s returning the following message:

The server is not available, retrying in 3 seconds

I tried to reinstall Realm Studio, connect with/out port, Connect using different users, and Connect using Admin Token.

I am still getting the server is not available message and retrying forever.
There are no firewalls installed on this Mac.

I tried to connect to Realm Cloud and was able to do so successfully. But I couldn’t connect to self-hosted server on Mac or to VM on Azure.

In the logs, I am getting this every time the Realm Studio tries to connect:

http: 127.0.0.1 - GET /health HTTP/1.1 401 24 - 0.734 ms

There are no errors or warnings.

Kindly, support me with this issue.

UPDATE#1:

I found Realm Browser which is a different program than Realm Studio. But, when I try to login , I am getting the following message stuck forever:

Connecting to an Object Server…


#2

@Alkhamisah Sounds like you are using an old version of the Realm Object Server - where did you get it, and how did you install it?

in the latest version of ROS you should no longer be able to browse to
http://localhost:9080/realms


#3

I used this link to download and configure the ROS on Mac.

After the installation, I was prompt to create an admin account in the “http://localhost:9080” page.
then, you can navigate to Realms on the side menu and actually see the Realms created successfully and work as expected. But, when I click on “Open in Realm Browser” , and try to login using account credentials or admin token, I am getting the message “Connecting to Object Server” forever or until Realm Browser crashes.

When I input random values as credentials, I am getting an error as expected. So, it’s a connection issue and not an authentication issue.


#4

@Alkhamisah Those docs are old - please follow these:
https://docs.realm.io/platform/self-hosted/installation

uninstall your Realm Object Server and install the new way: