Realm Studio 3.0.5 shows menu only



Realm Studio has just updated to 3.0.5 and now we don’t see any users or realms on our realm cloud instances (usa1a and de1a). All we see is the menu
The instances seem to be running just fine.


Had the same issue.

1.uninstalled the studio
2.delete C:\Users[Username]\AppData\Roaming\Realm Studio folder.
3.reinstall the studio

worked for me.



This was a bug with Studio 3.0.5 on Windows. We released a hotfix earlier today that should address it.


Thank you for the prompt repsponse @nirinchev . Realm Studio tried to update itself from 3.0.5 to 3.0.6 but returned Failed to update.


Yes - you’ll need to manually update it, sorry about that :slightly_frowning_face:


We’ve got the same issue with 3.0.7 failing to update. Is this something that will be fixed or should we expect to uninstall and reinstall for each update?


This is not expected - I filed a bug report in the Studio repo and we’ll reproduce and fix.


I am so sorry for these failing auto updates, we have work planned to implement post-packaging tests that exercise the automatic update feature, we have experienced multiple regressions and reported fixes that turned out had not fixed the issue in the library we’re using for this.

The recent versions of Realm Studio with an auto-updating issue on Windows is 3.0.5, and 3.0.6 - I verified that it was fixed with 3.0.7, which got released on Friday - that is - it will successfully auto-upgrade to the latest version once the next release is made.

Please get the latest version of Realm Studio for Windows at - Again, I am really sorry for the inconvenience this has brought on our Studio users on Windows!