Realm not support nodev72


(小猪侠) #1

use “yarn add realm” command, but not work.
node-pre-gyp info check checked for “/Users/zjz/Desktop/Projects/React/tool/node_modules/realm/compiled/node-v72_darwin_x64/realm.node” (not found)
node-pre-gyp http 404 https://static.realm.io/node-pre-gyp/3.2.0/realm-v3.2.0-node-v72-darwin-x64.tar.gz
@Realm @alexander


(Stephen Steneker) #2

@mymy3697166 The development team is currently working on Node 12 support.

The relevant GitHub issue to watch/upvote is https://github.com/realm/realm-js/issues/2516, which will add support for N-API with easier compatibility for future versions of Node.

The documentation should more clearly indicate supported versions as well as upcoming Node 12 support. I added a suggestion for this: https://github.com/realm/realm-js/issues/2552.

Regards,
Stennie