realm functions support not in cloud


I am working with realm, i enrolled for a trial cloud account and when I connect to it through realm studio, I can see the realm objects. I built the to do app using the tutorial and can see the sync happening. But I am unable to see where i can create a function which gets executed when data is updated.

I tried installing the on-prem version in my mac, it ran, i saw couple errors like failed binding, but at last I saw running successfully message. When i log into that server, i dont see synced realm objects ! But I can see a section where i can create functions. Hence i am confused what’s going wrong. Could it be because my mac does not have full admin power and binding to certain sockets are failining ?

cant i create a realm-function in trial account in cloud ?



You should read the documentation here:


Realm Functions have been deprecated in favor of using the Javascript and .NET SDKs directly. If you see functions in your local install, that means that it’s super old and not supported by any of the current SDKs or tools.


Thanks a lot for replying :slight_smile: I thought I was lost !

Ok. I see that I can write .net application using realm nuget package and keep that in some path to get executed . I will read more on this.

My problem is, why the realm objects are not syncing with my iphone to do list app. whereas they sync with cloud instance.

if i have installed an older version, how to uninstall, clean and fully install new ?


Ok, I am still confused where i can put data-change-events code in cloud version !


You have to host the code yourself. You can run a js or .NET app that handles and reacts to these changes and deploy that anywhere.


thanks. i am trying to write event-handlers using node.js

following this link

but where should i keep it ?

I tried keeping it at same level as my-app (~/realmtest/my-app) and copied the codes into index.js after creating the package.json . when i run node index.js i get syntax error from vm.js … bootstrapp.js and what not. really do not understand what is happening.

a step by step instruction will help. ream-functions were so much easier to work with !

if i start my server by saying ros init my-app … can i keep this inside this folder ?

i could not find a complete code, earlier in realm-functions, it used to write me a full java script function saying me insert , update , delete has happened… please help

tx in advance


this is so buggy, i tried .net code adding nuget package and what not , i get runtime error keychain exception keychain returned 25293

why it had to be so difficult ?