Partial sync disabled



I’m using the Partial synchronization and suddenly I’ve started to receive error upon creating a subscription:

RLMSyncError(_nsError: Error Domain=io.realm.sync Code=4 “Partial sync disabled” UserInfo={NSLocalizedDescription=Partial sync disabled, statusCode=214})

I’m currently on “realm/realm-cocoa” “v3.5.0” and it worked perfectly a couple days ago…


How are you opening the Realm? Are you using Realm Cloud or self-hosted?


I’m using Realm Cloud!


This is how I’m opening the Realm:

SyncUser.logIn(with: credentials, server: " … ") { user, error in
if let error = error {
} else {
let syncConfig = SyncConfiguration(user!: user, realmURL: " … ", isPartial: true)
let realmConfiguration = Realm.Configuration(syncConfiguration: syncConfig, objectTypes: [ … ])
let realm = try! Realm(configuration: realmConfiguration)




I’m receiving a similar error.

ERROR(error_code=214, message_size=21, try_again=0)

I’m using realm cloud.


The partial sync demo app that was previously working without problem (as downloaded complete version from getting started web page) is no long working. And throws the same error.


I’ve just tried a self-hosted Realm Object Server version 3.1.0 (not the last one) and it is working good!


@justcool @robac, I’ve done some more digging on the server side, and I believe it has to do with a recent version deployment. The team is debugging this now, and we should have this resolved soon.


Any updates on this? Realm Cloud is still broken for me, and all I get is the “Partial sync disabled” message when trying to connect.


+1 experiencing this same issue.

ERROR(error_code=214, message_size=21, try_again=0)


Any updates about the issue? I’m still getting Partial sync disabled.