I can not delete a lot of objects in Realm Studio


I think that Realm Cloud is wonderful.
I am using it and developing mobile app.
Also I am using Realm Studio.

But I found out a problem in Realm Studio.

I could delete about 10 objects from my classes list in Realm Studio by right click “Delete selected objects” after selecting objects.

But I could not delete about 30 objects by same way.

Realm Studio displayed this error message.

Error deleting the object:
object must be of type ‘object’, got (undefined)

Realm Studio Version is “1.21.0 (”.

My problem resolved by repeating delete.
But I hope that this topic help you develop Realm Studio.

Thank you.


@DonikaTachi Thank you for your support and feedback. Studio is an evolving product right now and generally geared for development. If you want to start deleting large chunks of data we would recommend using the realm-js APIs in a node.js app.


That does sound like a bug though - I’ll file an issue for the developers.


I just tried, but I cannot reproduce this error - do you think I could get access to the Realm that you are deleting objects from? By sending a local Realm or by creating an administrative user on your server and sending the password to my email address ([email protected]).


I can reproduce it easily in a Realm Cloud instance on the default realm… If i try to delete more than one it almost always sends this same error.


Same here.

Happens a lot if trying to delete large chunk of records.
The way to get around this for now is to delete only several records every time but would be nice if will be fixed.

by the way - any option to export data from cloud realm ?


Okay - I successfully reproduced this issue, sorry about my initial failure to do so.
We will be fixing this and releasing a patch soon.


We just released Realm Studio 2.1.1 with a fix for this - please verify that it indeed solves the issue.