How to add Facebook Auth to Real Cloud Authentication?


I am trying to use facebook auth in my app. I see that in self hosted app we can set auth provider with related keys for service. How do I do same in Cloud?


This is not yet possible with Cloud. We’re currently building the UI for enabling/disabling authentication providers and expect to have something ready very soon.


Hello, Is there a way we can set this using realm studio itself for cloud?


And is email auth supposed to work though?


@Revolt Yes, email auth is enabled by default.

@yalamber as I already mentioned, adding Facebook auth is not yet possible. When we roll out the updated portal, you will be able to configure that via the cloud dashboard.


I get

Error Domain=NSURLErrorDomain Code=-1001 “The request timed out.” UserInfo={NSUnderlyingError=0x600000258330 {Error Domain=kCFErrorDomainCFNetwork Code=-1001 “(null)” UserInfo={_kCFStreamErrorCodeKey=-2102, _kCFStreamErrorDomainKey=4}}, NSErrorFailingURLStringKey=, NSErrorFailingURLKey=, _kCFStreamErrorDomainKey=4, _kCFStreamErrorCodeKey=-2102, NSLocalizedDescription=The request timed out.}


Looks like you’ve added a port to your cloud url. Can you try removing it? The cloud instances are set up to route traffic to the standard ssl port (443), so there’s no need to explicitly specify it.


I just saw there is now jwt auth option, I guess we can use that with custom auth server to enable login through facebook.


any news on adding facebook login capability to Realm cloud?
Thank you


No update yet though it is something we’d ultimately like to do. For now, most users are opting to use JWT for auth integrations


If you don’t mind using Firebase it is pretty easy to set up Facebook authentication (or email or gmail or whatever you want) using Firebase Auth


I finally decided to build my own authentication server (it was quite easy using node js and passport), and on Realm now I only use JWT authentication, it works like a charm