Bad Server Version


#1

When using Realm Studio to connect to Realm Cloud and select “Realms” I continually get “Bad server version (IDENT, UPLOAD)”. After clicking reconnect I can then open my list of realms.

When I tried to log a ticket with support it failed to recognise my user email address and password - the same that I use to launch Realm Studio.

Additionally, once I do connect to my realms, when I attempt to delete one or more realms, the list of Realms clears and Realm Studio hangs. I have to close the window and select “Connect to Realm Cloud” again.


#2

Clearing the cache from the Help option in the initial Realm Studio screen fixed the problem. Maybe this should be included in the error message.


#3

Nix that. Clearing the cache works briefly then all of the issues start again.


#4

This is from the logs, don’t know if it will help;

https://synchronised-run-sheet.us1.cloud.realm.io/

v3.25.0
TokenValidator couldn’t check if token was revoked: The TokenRevocationRealm wasn’t opened.
The ‘Nickname’ auth provider has been enabled. This provider is not secure and should never be used in production deployments. If you’re still developing your application and experimenting, it is not a problem, but if this instance is hosting production data, please disable it immediately.
Failed to create emailHandler for config: {“connectionString”:“undefined”,“from”:“[email protected]”,“baseUrl”:“https://synchronised-run-sheet.us1.cloud.realm.io”}. Error: TypeError: Cannot create property ‘mailer’ on string ‘undefined’
Realm Object Server has started and is listening on http://0.0.0.0:9080
HTTP response: 5c5f5d96-fe1a-4cbe-8463-21cd6811a3fe {“type”:“https://docs.realm.io/server/troubleshoot/errors#invalid-credentials",“title”:"The provided credentials are invalid or the user does not exist.”,“status”:401,“code”:611}
HTTP response: 41a24c29-8162-4885-97bf-19dfa6d13999 {“type”:“https://docs.realm.io/server/troubleshoot/errors#invalid-credentials",“title”:"The provided credentials are invalid or the user does not exist.”,“status”:401,“code”:611}


#5

Also tried logging out, clearing the cache and logging in again.


(Brian Munkholm) #6

Is this something you are experiencing with Realm Cloud?
We have identified a bug that potentially could appear like this and will be rolling out a fix shortly.


#7

Yes the problem occurs with Studio and Realm Cloud.


(Brian Munkholm) #8

@RayBrack Sorry I didn’t revert to you, but the problem should have been fixed last weekend. Do you still expereince the issue?


#9

Sorry for the late reply - everything is working again.


(Kræn Hansen) #10