[Apple Xcode 9] (ERROR) No viable overloaded '='


Hello all

I just install Xcode 9 and build my native iOS project. (Is written in objetive c and swift)

The project was OK in Xcode 8 but now, I obtain this error:

No viable overloaded '='

In the file: Pods\Pods\Realm\ results.cpp

Line 273 => m_notifier = std::make_shared<_impl::ResultsNotifier>(*this);

And the same error in
Line 539 => m_notifier = std::make_shared<_impl::ResultsNotifier>(*this);

How can I fix this?

Thanks you


I’ve met the same problem


I have encountered the same problem on Xcode 9 Beta. My swift project was working prior to this.


Hello, Can anyone help us?



Hi all! Sorry for the late reply. We were all out at WWDC last week.

We released a new version of Realm yesterday, v2.8.1 that we’ve worked to ensure works with the latest Xcode betas.
Please update your version of Realm in your app to that version and let us know if you’re still having issues.



Hi, I’m pulling in Realm via npm for a React Native application and seeing the same error in Xcode 9. Any possibility of the npm dependency getting an update? (Seeing the latest version as v1.3.1)


Looks like Realm’s NPM package was updated to v1.8.0 and is compiling with Xcode 9 beta.


Hi Tim,
my RealmSwift is installed with Cocoapods. Is there a particular way I need to do the update in order to get it to work with XCode 9?
Currently podfile says:

pod ‘RealmSwift’


I had the same error, going through the “Santa Tracker” tutorial. I was finally able to eliminate it by removing the “2.1.0” specification from the “pod RealSwift” in the pod init file. This updated my RealmSwift from 2.1.0 to 3.1.1, and this removed this particular terminal error.